Complete
Maintenance has completed
In progress
The expected maintenance has been completed and the team is currently undergoing verification and monitoring.
In progress
Maintenance has started
Scheduled
Our engineers will be performing maintenance to continue to improve the service offering.
During this time, you will not be able to login, create or update a Thermometer or view the Reporting.
There might be some disruption to responses left, which will be queued and then later processed after the maintenance window has closed.